Title

Message
Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Windows 10 Creator Update - Window Focus Issue

Avatar from Gravatar.com
CorneliousJD
3 discussion posts
When DisplayFusion is open for a while my windows won't always let go of focus properly.

A good example is if I'm using Chrome, and try to bring up any other app that's running behind Chrome by clicking the icon on the taskbar it won't actually show up in front of Chrome unless I click it 5-10 times or until I minimize Chrome.

This happens on any of my 4 monitors with any programs, another example that it happens with is QuickBooks and Outlook.

If I close DisplayFusion it starts working again correctly, and will continue to work for a random amount of time if I reopen DisplayFusion, but the problem seems to always come back.

This didn't start happening to me until I updated to the Windows 10 Fall Creators Update, but on the forums I see this being a somewhat uncommon issue, but it certianly has happened to others, not sure how to fix it in my case though.
Nov 20, 2017  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
On the Settings > Taskbar tab, could you try setting the Window Preview Style to "Previews disabled, show group list on hover" and see if that makes any difference? (this is just a test, not a permanent solution)
Nov 21, 2017  • #2
Avatar from Gravatar.com
CorneliousJD
3 discussion posts
I'm waiting for it to happen again before I make any changes - I'll let you know. I wont be on the PC too much between now and Monday because of the holiday weekend here in the States.

I'll keep you posted if I see this stop after making the changes.
In the meantime are you able to let me know why this may be the case? I really do like the window previews being there on the other monitors, but this does even happen on my main monitor as well FYI.

Thanks!
Nov 22, 2017  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok sounds good, have a great holiday weekend!
Nov 23, 2017  • #4
Avatar from Gravatar.com
CorneliousJD
3 discussion posts
So this hasn't happened for a few days now but i haven't changed any settings. I'll keep this forum link handy if it comes back and report back then. Thank you!
Nov 28, 2017  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Sounds good, thanks for the update!
Nov 30, 2017  • #6
Avatar from Gravatar.com
eightBitSheep
7 discussion posts
Quote:
On the Settings > Taskbar tab, could you try setting the Window Preview Style to "Previews disabled, show group list on hover" and see if that makes any difference? (this is just a test, not a permanent solution)


Having the same issue (I previously made a post about this two years ago and didn't realize you responded back Keith, I apologize for that) (original post here: https://www.displayfusion.com/Discussions/View/windows-10-always-on-top-randomly/?ID=e9623999-49fd-4781-8508-e75a46b56441) It's worth mentioning the problem was happening only with DisplayFusion running, sorry about the confusion on the previous post. I have also tried some of the suggested stuff from the tread you linked.

Cornelious is an IRL friend who didn't have the problem up until recently, I haven't had the problem in about a year after turning off the DisplayFusion Multi Monitor taskbars (well leaving DisplayFusion running). I turned them on again a few days ago and it started happening. Cornelious sent me this and I tried what was suggested and it did not correct the problem.

Do you have any further suggestions?
Jan 7, 2018  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Can you attach a new copy of your troubleshooting info?

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached
Jan 9, 2018  • #8
Avatar from Gravatar.com
eightBitSheep
7 discussion posts
Here it is
• Attachment [protected]: DisplayFusionDebugInfo.zip [23,671 bytes]
Jan 9, 2018  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@eightBitSheep: If you position your taskbars on the bottom instead of the sides, does this stop happening?
Jan 10, 2018  • #10
Avatar from Gravatar.com
eightBitSheep
7 discussion posts
Quote:
@eightBitSheep: If you position your taskbars on the bottom instead of the sides, does this stop happening?


I just switched it to "Automatic" instead of "left" it's now at the bottom, I'll respond in a few days with my results. Thank you.
Jan 10, 2018  • #11
Avatar from Gravatar.com
eightBitSheep
7 discussion posts
Quote:
@eightBitSheep: If you position your taskbars on the bottom instead of the sides, does this stop happening?


Wanted to follow up, switching the taskbar to automatic positioning which placed it at the bottom seems to have fixed the issue.
Jan 14, 2018  • #12
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, thanks for following up! We had fixed that issue and it seemed fixed for most, but there must be something specific about your system (and Cornelius' as well) that's still triggering this issue.

If we're able to figure it out and get it sorted, we'll definitely let you know.

Thanks!
Jan 16, 2018  • #13
Avatar from Gravatar.com
Vincent D
2 discussion posts
I only recently upgraded to Windows 10 Creator Update and am also now experiencing window focus issues when DisplayFusion is running. As of now, it seems to only occurs with Chrome. I have not yet noticed it with other apps. It happens about 2/3 of the times. When it happens, sometimes if I keep clicking on the icon then it comes up. Other times I have to minimize the other windows to get to Chrome.

I am attaching the debug info if it is any help.

EDIT: Forgot to add that I do have SetWindowPos set to "Disallow TopMost Calls" as recommended in other places. But I did that a while ago when I first installed Windows 10. This problem is much more recent.

EDIT 2: Also tried "Previews disabled, show group list on hover" in Taskbar settings but no difference I can see right away.
• Attachment [protected]: DisplayFusionDebugInfo.zip [25,464 bytes]
Jan 16, 2018 (modified Jan 16, 2018)  • #14
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It could also be another application on your system, as any application that uses TopMost calls can trigger this bug in Windows. The next time the issue occurs, if you exit DisplayFusion, does that immediately resolve it?
Jan 17, 2018  • #15
Avatar from Gravatar.com
eightBitSheep
7 discussion posts
Quote:
It could also be another application on your system, as any application that uses TopMost calls can trigger this bug in Windows. The next time the issue occurs, if you exit DisplayFusion, does that immediately resolve it?


I still havent had any issues since I changed the taskbar location however. when I was having it, closing DisplayFusion fixed it right away and opening DisplayFusion right away would not cause it to happen right away it would happen randomly during normal PC usage.
Jan 17, 2018  • #16
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! I think the cause on your machine is different than Vincent's. Vincent, does exiting DisplayFusion when the issue occurs immediately fix it?
Jan 18, 2018  • #17
Avatar from Gravatar.com
Vincent D
2 discussion posts
Sorry it took me so long to reply but I wanted to wait a while to make sure I can confirm the problem.

I can confirm that yes the problem stops right away when closing DisplayFusion.

Unfortunately for the rest I really have not been able to find a specific action that triggers the problem reliably. What's hard is that even when it is occurring, if I click back and forth between chrome and another window, it happens on some clicks but not others...

I can also say however that at times it also occurs with Windows File Explorer, but maybe not as regularly as with Chrome.

I am afraid this isn't much help as far as finding the source of the problem... I'll keep you posted if I find some more reproducible behavior.
Apr 12, 2018  • #18
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, sounds good, thanks!
Apr 17, 2018  • #19
Avatar from Gravatar.com
dvdgsng
1 discussion post
Hi Keith, I too have been troubled by this bug for some time now. Previously I tried to work around it by setting "SetWindowPos: Disallow TopMost Calls", as recommended on the Windows 10 Known Issues page, but without success ... Chrome-based applications still need to be clicked several times before gaining focus.

However the good news is that after switching my two additional (DisplayFusion) taskbars from "Left"/"Right" to "Bottom" or "Automatic", the bug is gone (as you suggested in this thread). While I can live with this workaround, I'd rather see this bug resolved properly so i can use my preferred taskbar positions. Are you still looking into resolving this?

Cheers
David
Jun 19, 2018  • #20
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It's not really something we can fix from our end. It's a Windows bug that's triggered by our taskbars being on the side for some reason, though for most folks, disabling the topmost calls fixes it. Can you run with the taskbars on the bottom for a bit longer to 100% confirm that it doesn't happen any more with them there? It's possible that another application using topmost calls could be triggering the bug as well.
Jun 21, 2018  • #21
Was this helpful?  Login to Vote(2)  Login to Vote
<< DiscussionsReply