Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply
Show Desktop button doesn't work when Display Fusion taskbar is showing all windows.
Avatar from Gravatar.com
Brendon Rogers
4 discussion posts
I have been using Display Fusion for quite a while now and this is the only issue I have ever had with it.

Basically I'm using two monitors, one with my windows taskbar on it and one with the display fusion taskbar on it.

I chose to put all running applications on the display fusion taskbar. Making my windows taskbar appear empty.

However, now the show desktop button on my windows taskbar dosen't work correctly. It dosent minimize the windows on the primary monitor. Probably because none are actually registered since they are all on the display fusion taskbar.

So I am just wondering if there is anyway around this?
Feb 12, 2015 (modified Feb 12, 2015)  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Binary Fortress Administrator
 Binary Fortress Administrator
Could you attach a copy of your troubleshooting info? Here are the steps:
  • Open the DisplayFusion Settings > Troubleshooting tab
  • Click the Copy to Clipboard button
  • Open Notepad, paste the text, and save the file
  • Reply with the text file attached

Thanks!
Feb 13, 2015  • #2
Avatar from Gravatar.com
Brendon Rogers
4 discussion posts
Sure

Here it is.
• Attachment [protected]: trouble shooting.txt [73,110 bytes]
Feb 13, 2015  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Binary Fortress Administrator
 Binary Fortress Administrator
Thanks! I tested your setup on a machine here, but couldn't reproduce the issue. Are you running Stardock Fences (for desktop icons) by any chance?
Feb 13, 2015  • #4
Avatar from Gravatar.com
Brendon Rogers
4 discussion posts
Yeah I am actually.

Do you think that is interfering with it?
Feb 13, 2015  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Binary Fortress Administrator
 Binary Fortress Administrator
Yep, unfortunately there's a compatibility issue between DF and Fences that causes the Show Desktop function in Windows to act funky. It only happens if both Fences and DF are running, but we haven't been able to figure out why. It's still on our list, so if we're able to get it sorted in a future version, I'll be sure to let you know!
Feb 13, 2015  • #6
Avatar from Gravatar.com
Brendon Rogers
4 discussion posts
Yeah you are right, disabling fences fixed the issue.

But it still works with fences enabled, as long as display fusion starts before fences on windows start up.

So can you suggest any program to configure a queue for start up programs?
I remember seeing you mention one on a discussion somewhere..
Feb 13, 2015  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Binary Fortress Administrator
 Binary Fortress Administrator
Yeah, it's a hook chain issue :(

There's an app called Startup Delayer that works pretty well, but I couldn't get it working with Fences, because Fences seems to run as an Explorer shell extension, so it doesn't have it's own startup item. If you're able to get it working, definitely let me know :)
Feb 18, 2015  • #8
Avatar from Gravatar.com
Eric Burgler765954
1 discussion post
If you are using fences, there is a way to get the 'Show Desktop' button to work. This is done by going to 'Configure Fences' --> 'Quick-hide' --> 'Settings' --> Check the 'Enabled' box.
• Attachment [protected]: Fences Config.png [111,706 bytes]
Sep 6, 2017  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Binary Fortress Administrator
 Binary Fortress Administrator
Oh nice, thanks for the heads up!
Sep 7, 2017  • #10
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply
Visit DisplayFusion on FacebookVisit DisplayFusion on TwitterVisit DisplayFusion on Google+Visit DisplayFusion on LinkedInSearch for DisplayFusion on RedditFollow DisplayFusion on RSSVisit DisplayFusion on Instagram
Copyright © 2007-2017 Binary Fortress Software • News • Discussions • 常見問題集 • 支援 • Privacy • ToS