Title

Message
Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

DisplayFusion lags when waking up computer using dual 4K monitors

Avatar from Gravatar.com
MDVillarreal
15 discussion posts
I recently upgraded to dual 4K monitors (for reference, my monitor setup is a Cintiq 22HD and 2 4K monitors). Whenever I wake the computer up (moving the mouse after the screens have gone black from inactivity), the wallpapers always mess up and sometimes load up in the wrong monitors and my mouse (wireless Logitech M570) will lag badly. Sometimes it will correct itself after a few minutes, but lately I've noticed it seems to correct if I open the Task Manager, which doesn't make any sense to me. I didn't have any issues prior to the 4K monitors, so I'm not sure if my problem is related to DisplayFusion, Windows 10, or a mix of both. I am using Display Fusion Pro 9.1.

EDIT: It also looks like Display Fusion is consuming about 15-25% of the CPU when this happens (at normal use, it's usually 1% or less).
Dec 18, 2017 (modified Dec 19, 2017)  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
If you disable the DisplayFusion Multi-Monitor Taskbars before sleeping the computer, do you still run into this issue when waking it up?
Dec 20, 2017  • #2
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Hello. Disabling the multi-monitor taskbars has just about eliminated that problem in my testing thus far. Is the multi-monitor taskbar the likely culprit then? This was after manually setting the computer to sleep.

EDIT: Did not solve the problem as I thought. Though the lag problem isn't as bad as it was and it doesn't take as long to straighten back out, it still takes longer than I think it should. Multi-monitor taskbar is still disabled. This is what occurs after moving the mouse to wake the computer up (computer is still on, just in light sleep mode from inactivity).
• Attachment: problem_example.jpg [883,487 bytes]
Dec 22, 2017 (modified Dec 22, 2017)  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Yeah, Windows likes to mess up the wallpaper when monitors sleep, the correction you're seeing 30-60 seconds later is DisplayFusion detecting that and fixing it up.

Is the mouse lag gone since the taskbars were disabled?
Dec 22, 2017  • #4
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
This is another thing that occurs sometimes when waking the computer up.

The mouse lag occurs for as long as it takes for Display Fusion to get everything straightened out. This wasn't an issue when I had all 1080p monitors, but it became one once I upgraded to 4K monitors.
• Attachment: problem_example2.jpg [710,565 bytes]
Dec 24, 2017  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Strange that the Windows taskbar is ending up in such a weird spot. Can you attach a copy of your troubleshooting info?
  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached
Jan 2, 2018  • #6
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Here is the info requested today.
• Attachment [protected]: DisplayFusionDebugInfo.zip [21,795 bytes]
Jan 4, 2018  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks, if you also disable the DisplayFusion Desktop Wallpaper, do both problems (the mouse lag and the weird Windows taskbar position) go away completely?
Jan 4, 2018 (modified Jan 4, 2018)  • #8
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Disabling the wallpaper minimizes the amount of time the mouse lags when waking up the computer (down to just a few seconds), but it always occurs when waking the computer from a sleep state or dormant state. The taskbar doesn't always jump to weird places, only on occasion.
Jan 5, 2018  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you check something for me?

  • Go to Windows Settings > System > Power & sleep
  • Click "Additional power settings" on the right side
  • In the Power Options window that opens, click "Change plan settings" next to the currently active power plan
  • Click "Change advanced power settings"
  • Expand "Processor power management" and each sub-section underneath it
  • Let me know what each value is set to
Thanks!
Jan 9, 2018 (modified Jan 9, 2018)  • #10
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Under processor power management it says:
- Minimum processor state setting: 5%
- System cooling policy setting: Active
- Maximum processor state setting: 100%.
Jan 10, 2018  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
If you change the minimum processor state to 100%, does that make any difference?
Jan 10, 2018  • #12
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
That makes no difference. It is still laggy and takes a few seconds for the screens to correct themselves as before when waking up from an inactive state.
Jan 12, 2018  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, one last thing to try. Could you try enabling the "General: Run as a Low Priority Process" option in the DisplayFusion Settings > Advanced Settings window, then restart DisplayFusion and see if that makes a difference?
Jan 16, 2018  • #14
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Did not make a difference.
Jan 17, 2018  • #15
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
I only have DisplayFusion issues whenever waking up the computer from an idle state (such as when the monitors have gone blank from inactivity, but the computer is still on). I don't have any issues any other times with it.
Jan 21, 2018  • #16
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, that's good to know! I think this may be related to a similar issue we're trying to track down. I'm going to add your info to that ticket, and we'll let you know when it's fixed up so that you can re-test.

Thanks!
Jan 23, 2018  • #17
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Would you be able to try out DisplayFusion 9.2 Beta 1 to see if the issue still exists?
Apr 27, 2018  • #18
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I have some hopefully very good news! I was finally able to reproduce the runaway CPU consistently here, and we're 99.99999% sure that we've gotten it fixed up. We released 9.3 this morning, but then found and fixed the CPU bug, so we've reposted it as DisplayFusionSetup-9.3c.exe. If you've already updated to 9.3, could you re-download it from our website and install it? Double-check that the setup file downloads as DisplayFusionSetup-9.3c.exe.

Thanks!
Jun 27, 2018  • #19
Avatar from Gravatar.com
MDVillarreal
15 discussion posts
Hello! I apologize for my lack of response. I have just downloaded and installed 9.3c. I will test it over the weekend and see how it does.
Jun 28, 2018  • #20
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, sounds great! Keep us posted
Jun 30, 2018  • #21
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply