Title

Message
Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Can't get 144Hz in fullscreen windowed mode because of DisplayFusion?

Avatar from Gravatar.com
Mgs
20 discussion posts
I recently purchased a 144Hz monitor, it is setup correctly and displaying 144Hz in Windows. While playing Heroes of the Storm in fullscreen windowed mode (with another 60Hz monitor also plugged in), I noticed I wasn't seeing 144Hz in game. When I switched to normal fullscreen mode I could see the difference clearly. But back in fullscreen windowed it looked like what I'm used to (60Hz). I figured it was an issue with the game or something, until I tried exiting out of DisplayFusion and it started working just fine in fullscreen windowed mode.

So somehow DisplayFusion is limiting my refresh rate in a fullscreen windowed game to 60Hz because I have another 60Hz monitor connected. If only the 144Hz monitor is connected it works fine there too. Any ideas for settings that could be interfering?
Jan 6, 2018  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We ran into this a while ago with the Windows Start menu animation, but I didn't notice it affecting games when I tested. I won't have a chance to test this week, but next week I'll have a go at it and see if I can reproduce this here as well.
Jan 10, 2018  • #2
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, I had a chance to do some testing on this, and I was able to reproduce it here. It looks like it's a Windows and/or driver issue, triggered by some other DWM window running at 60 Hz, as other people have this issue when playing a video on the 60 Hz screen as well:

  • http://www.tomshardware.com/answers/id-3518735/dual-144hz-60hz-monitors-locked-60hz-watching-video-gaming.html
  • https://www.reddit.com/r/nvidia/comments/4i4399/dual_monitor_144hz_60hz_framerate_lock_is_a_bug/#bottom-comments
There aren't any helpful solutions in those threads other than "don't run the thing that's causing this issue." :(

In our case, it's the DisplayFusion taskbar, so as a workaround for now, you could add a Compatibility rule in the DisplayFusion Settings to disable the DisplayFusion taskbar when the game starts. I will also add this to our list to look into further (maybe there's a way to force it to run at 144 Hz?) and if we're able to find a solution, we'll definitely update here.

Thanks!
Jan 16, 2018  • #3
Avatar from Gravatar.com
Mgs
20 discussion posts
Thanks Keith, I appreciate you looking into this!
Jan 16, 2018  • #4
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply